Skip to content

protobuf version conflict with tensorflow #339

Closed

Description

Tensorflow 2.9.1 requires protobuf<=3.20.0 but dm_control requires protobuf>=3.20.1. How does deepmind internally even work on their AI systems with this going on? I don't understand.

Activity

  1. saran-t commented on Sep 5, 2022

    @saran-t
    Member

    Looks like the the protobuf<3.20 requirement in TensorFlow is there because of a link error that only exists on Windows https://github.com/tensorflow/tensorflow/blob/master/tensorflow/tools/pip_package/setup.py#L88

    Internally, we share a monorepo with Google, which means that first-party like tensorflow, dm_control, and protobuf are kept compatible with each other "at HEAD", rather than with specific versions. (In short, we don't rely on Git or PyPI packages.)

    I'll lower the protobuf version requirement in dm_control for our next release (which will hopefully come out this week).

  2. saran-t commented on Sep 7, 2022

    @saran-t
    Member

    This is now fixed in version 1.0.6.

  3. added a commit that references this issue on Oct 14, 2025
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions