You signed in with another tab or window. Reload to refresh your session.You signed out in another tab or window. Reload to refresh your session.You switched accounts on another tab or window. Reload to refresh your session.Dismiss alert
{{ message }}
This repository was archived by the owner on Jul 29, 2026. It is now read-only.
Repository navigation
This repository was archived by the owner on Jul 29, 2026. It is now read-only.
yarn install v1.3.2
warning package.json: "dependencies" has dependency "babel-core" with range "^6.18.2" that collides with a dependency in"devDependencies" of the same name with version "^6.6.5"
warning package.json: "dependencies" has dependency "babel-preset-es2015" with range "^6.18.0" that collides with a dependency in"devDependencies" of the same name with version "^6.6.0"
info No lockfile found.
warning angular-fullstack-generator@0.0.0: "dependencies" has dependency "babel-core" with range "^6.18.2" that collides with a dependency in"devDependencies" of the same name with version "^6.6.5"
warning angular-fullstack-generator@0.0.0: "dependencies" has dependency "babel-preset-es2015" with range "^6.18.0" that collides with a dependency in"devDependencies" of the same name with version "^6.6.0"
[1/5] 🔍 Validating package.json...
error angular-fullstack-generator@0.0.0: The engine "node" is incompatible with this module. Expected version "^6.2.2".
error Found incompatible module
info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.
I'm not sure if the supported Node.js version is still 6. If that is the case, everything works as supposed.
You can either downgrade your Node to >= 6.2.2 && < 7.0.0 or use yarn install --ignore-engines after the initial installation fails and see if it works without any compatibility issues.
Could you give feedback if you run into the problem #2694 afterwards?
We should change it to be >= the latest acceptable 6.x.x version, probably. I wouldn't be against making the minimum node version in the 8.x.x range either, since it's LTS now.
@albert-92 in the project the gulpfile.babel.js was not found after run the generator.. i guess that for install the 5.0.0-rc-0 you need to use node >= 8 so there is no reason to downgrade Node
Activity
albert-92 commentedon Mar 15, 2018
I'm not sure if the supported Node.js version is still 6. If that is the case, everything works as supposed.
You can either downgrade your Node to
>= 6.2.2 && < 7.0.0or useyarn install --ignore-enginesafter the initial installation fails and see if it works without any compatibility issues.Could you give feedback if you run into the problem #2694 afterwards?
Awk34 commentedon Mar 15, 2018
We should change it to be
>=the latest acceptable 6.x.x version, probably. I wouldn't be against making the minimum node version in the 8.x.x range either, since it's LTS now.albert-92 commentedon Mar 16, 2018
@Awk34 That sounds reasonable. I'll test it with the latest LTS release 8.10.0 and report if i find any compatibility issues.
daton89 commentedon Mar 16, 2018
@albert-92 in the project the gulpfile.babel.js was not found after run the generator.. i guess that for install the 5.0.0-rc-0 you need to use node >= 8 so there is no reason to downgrade Node
albert-92 commentedon Mar 16, 2018
@daton89 upgrade to 5.0.0-rc-1, the gulpfile.babel.js problem is fixed there and then run
yarn install --ignore-enginesif you want to use node 8.It looks like generator-angular-fullstack works with either node 6 or node 8 just fine.
fix(app): wrong engines in package.json angular-fullstack#2696
Merge pull request #2702 from albert-92/fixes-5.0.0rc1